[Greasemonkey] Greasemonkey 0.3

Aaron Boodman zboogs at gmail.com
Sat Apr 16 21:00:47 EDT 2005


Thanks for the detailed description of the problem, I'll fix this bug.

Looks like your description of the problem is accurate: you had
already manually migrated, but the preference that migration sets was
not there, so it kept trying to migrate.

You could also fix this in your case by adding that prefrence in about.config:

greasemonkey.pointThreeMigrated = true

or whatever it is.

On 4/16/05, Bill Donnelly <donnelly at snowcrest.net> wrote:
>  I got a similar error installing .03a,
>  except it renamed my scripts directory
>  to ununderline.user.js. (the first
>  script name listed in the scripts list)
>  
>  I think the problem is that it is trying
>  to migrate to the new format even though
>  it was already done manually.
>  
>  Also, when I selected the Tools |
>  Manage User Scripts... menu item,
>  it didn't do anything.
>  (because no scripts were installed?
>  Worked via Extensions dialog Options button.
>  
>  But the Cancel button doesn't work.
>  (as reported elsewhere)
>  
>  So, in config.xml, it changed all of the
>  script references to:
>  
>  <Script filename="" name=.....
>  
>  So, I fixed them manually, and it still tried to
>  migrate the next time I started FF and it erased
>  my changes again. Here is the JS error from the
>  JS Console, which occured after the last logged
>  message "Greasemonkey: renaming script scripts to linkify.user.js":
>  
>  Error: [Exception... "Component returned failure code: 0x80520012
>  (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.moveTo]"  nsresult: "0x80520012
>  (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
>  chrome://greasemonkey/content/greasemonkey.js ::
>  GM_pointThreeMigrate :: line 540"  data: no]
>  Source File: chrome://greasemonkey/content/greasemonkey.js
>  Line: 540
>  
>  I looked at the code and it is trying to do it again
>  because it didn't set the pointThreeMigrated preference.
>  So I just made the GM_pointThreeMigrate function return
>  without doing anything. This code needs to be spiffed up some.
>  It worked when I did the mod.
>  
>  btw -- that Edit button is a bit odd. (?)
>  I can see a View script button, but Edit?
>  Especially for "users". (versus programmers)
>  (and it didn't work on Millennium Edition, even tho
>  most things of that nature work -- I think the problem
>  might be that .JS isn't defaulted to "edit", and
>  I don't think we want it to be (?) --- because that
>  would mess up other stuff (?))
>  
>  Eddie S wrote: 
> I got an alert box saying there was an error.
>  It didnt update config.xml with the names it just gave the files. It
>  didnt know where the scripts were as it renamed the folder. Whenever i
>  right clicked "add user script" was visable. And generally confused
>  itself.
>  
>  After renaming the script folder back to scripts. Updating the
>  config.xml file it now works again. But a file in the new name.user.js
>  confused it. Just thought i would let you know.
>  
>  
>  
> _______________________________________________
> Greasemonkey mailing list
> Greasemonkey at mozdev.org
> http://mozdev.org/mailman/listinfo/greasemonkey
> 
> 
>


More information about the Greasemonkey mailing list