[Greasemonkey] installing 0.3b

Jeremy Dunck jdunck at gmail.com
Sat Apr 23 22:32:28 EDT 2005


On 4/23/05, Bob Herrmann <bob at jadn.com> wrote:
> 
> When I click on this link,
>         http://youngpup.net.nyud.net:8090/greasemonkey_0.3b.xpi
> 
> Firefox asks where to download the file.   It's like the mime/type isn't
> correct.

That is indeed the case (see below).  That can easily be fixed by
setting the mime type on the server.  As a workaround, you can use
FF's File > Open command to open the saved file, which should then
open the expected extension install screen.

Additionally, I'm getting the "Not a valid install package" error,
even after repeated attempts.  I think we may need to start publishing
an MD5 for the file...

GET /greasemonkey_0.3b.xpi HTTP/1.1
Host: youngpup.net.nyud.net:8090

...

HTTP/1.x 200 OK
Server: Microsoft-IIS/5.0
Content-Type: application/octet-stream
Content-Length: 19786


More information about the Greasemonkey mailing list