[Greasemonkey] gmdetect.js

Mark Pilgrim pilgrim at gmail.com
Tue Jul 19 10:19:16 EDT 2005


I've written a Greasemonkey vulnerability detection script and
installed it on diveintogreasemonkey.org and diveintomark.org.  If it
detects leaking APIs, it displays a warning message telling the
visitor that the version of Greasemonkey they are using has critical
security flaws, and points them to the Greasemonkey home page for
download, or the specific mailing list message that gives details on
the vulnerability.  Has no ill effects in IE, Opera, Safari, Firefox
without Greasemonkey, or Firefox with GM 0.35.

Available here:  http://diveintogreasemonkey.org/download/gmdetect.js

Open source, MIT-licensed.  Just drop it into any page, no
initialization required:

<script type="text/javascript" src="/path/to/gmdetect.js"></script>

-- 
Cheers,
-Mark


More information about the Greasemonkey mailing list