[Greasemonkey] GM-TNG - several bugs fixed
coretxt at gmail.com
Thu Jul 28 19:21:46 EDT 2005
> > >I named it "unsafeWindow" to make it clear that the functions and
> > >properties in this window are not to be trusted. But maybe it would
> > >make more sense - and be less scary - to just call it "contentWindow".
> "contentWindow" does seem like a more descriptive name to me than
> "unsafeWindow". Maybe it's not too late to change this?
Yes, unsafeWindow does sound quite paranoid - but completely
understandable, given the very real feelings of shock I experienced
last week when seeing Mr Pilgrim's page reading out information about
files on my C drive...
More information about the Greasemonkey