[Greasemonkey] GM-TNG - several bugs fixed

John Plsek gm at plsek.id.au
Thu Jul 28 17:37:48 EDT 2005

Mark Rickerby wrote:

>>>>I named it "unsafeWindow" to make it clear that the functions and
>>>>properties in this window are not to be trusted. But maybe it would
>>>>make more sense - and be less scary - to just call it "contentWindow".
>>"contentWindow" does seem like a more descriptive name to me than
>>"unsafeWindow". Maybe it's not too late to change this?
>Yes, unsafeWindow does sound quite paranoid - but completely
>understandable, given the very real feelings of shock I experienced
>last week when seeing Mr Pilgrim's page reading out information about
>files on my C drive...
>- Mark
>Greasemonkey mailing list
>Greasemonkey at mozdev.org
Why not. unsafeContentWindow ... or better still, 
unsafeContentOnlyUseIfYouKnowWhatYouAreDoingWindow ... the sheer length 
of that will deter people from using it too much ;)

personally, from an "author of a script" point of view, I think 
unsafeWindow is more appropriate (built in early warning system in that 

from an "end user of a script" point of view (i.e., with no knowledge of 
the innards of greasemonkey), I can imagine looking through some 
scripts, seeing "unsafeWindow" ... and backing away from the script 
slowly, avoiding all eye contact!!!


More information about the Greasemonkey mailing list