[Greasemonkey] Greasemonkey 0.4.2 - Voyager

Bill Donnelly donnelly at snowcrest.net
Thu Jul 28 06:06:52 EDT 2005


I uninstalled Gm 0.4.2. (quit Ffx, restarted Ffx, quit Ffx)

Manually delete the Gm {GUID} directory in the Ffx extensions directory.

Manually deleted all of the "Greasemonkey" config values in prefs.js.
(Gm never modified 'version' to "0.4.2")

Installed 0.4.2. --- Worked.
Installed a couple of scripts. --- Worked.
Scripts worked.
"Install This User Script..." is dimmed/enabled appropriately.

But, every time I install a script, or go into the Manager dialog,
I get the following error in JS Console:

   Error: [Exception... "Component returned failure code: 0x80004001
   (NS_ERROR_NOT_IMPLEMENTED) [nsIRequest.name]"
   nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"
   location: "JS frame :: chrome://greasemonkey/content/browser.js ::
   anonymous :: line 422"  data: no]
   Source File: chrome://greasemonkey/content/browser.js
   Line: 422

Other than that, so far, so good.

Don't fret. It's a miracle you got done what you got done.
Thanks for all of your guy's hard work.

And never forget: Debugging is Our Friend!

;) ;o)

-- 
Jack the Ripper may have been quite insane,
but he had beautiful penmanship.
btw -- Don't look back!
The lemmings are gaining on you.



More information about the Greasemonkey mailing list