[Greasemonkey] "Manage User Scripts..." not working?

GuidoZ uberguidoz at gmail.com
Sat Jul 30 01:36:11 EDT 2005

Hello list - I just signed up and installed GreaseMonkey today, so
pardon my ignorance if this question gets answered a lot. To start
with, I'm certainly not a n00b to Firefox or computer in general, so
feel free to try and help however you can. =) On a side note - GM is
BRILLIANT. I'm very, VERY happy with what I've been able to do so far
and have started dreaming of new things.

Some helpful background info...

My OS: Windows XP Pro
Browser: Firefox 1.0.6
GM version: 0.3.5

Everything *seems* to be working fine - GM is installed and I can
install user scripts (via right-click on the link). The scripts are
also working... amazing extension. The hacking ideas are already
making my mind jump through hoops! But I digress.

I wanted to add some URLs to a script I have installed (that is
working). I checked out the documentation quickly and figured I'd pop
into the "Manage User Scripts..." (MUS from now on) settings, then
edit that script by adding the necessary URLs. Sounded simple enough
and made perfect sense.

The issue I ran into - I can't open the MUS window/menu/etc. The
option is there in the Tools menu, right below the "Install User
Script...". It's not greyed out either - I can click it, but nothing
happens. No window opens up. Nothing flashes or even peeps. The Tools
menu disappears and I'm back at whatever page I was currently on with
no change. (FYI: This also happens with the "Install User Script..."
option in the Tools menu. I can only install via right-click on the
.js link.)

I've tried disabling GM via the monkey head icon (cute). Rebooting
Firefox. Rebooting system. Uninstalling/Reinstalling. Nothing. My only
guess is that it's clashing with an installed script (although I
noticed this very early on) or an installed extension. I didn't see
any extensions I have installed listed as conflicting, but just in
case here is a list of them all: (32 total)

AdBlock v0.5.2
BugMeNot v0.6.2
ChromEdit 11-22-04
Compact Menu 04-19-05
Configuration Mania v1.05 (02-19-05)
CookieCuller v1.2.0
Copy Plain Text v0.3
Diggler v0.9
Disable Targets for Download v1.0
Download Manager Tweak v0.6.6
DownThemAll v0.9.4
ForcastFox v0.8.1.1
Gcache v0.2.1
Googlebar v0.9.5
Greasemonkey 0.3.5
IE View v1.2.4
ImageZoom v0.1.7
JumpLink v1.3.1
Magpie v3.1.2
Nuke Anything v0.2
Open Link In v1.3
Platypus v0.5
ReloadEvery v0.6.1
ResizeSearchBox v1.0
Spiderzilla v1.0.6
SwitchProxy v1.3
Tab Mix v0.2.2.3
Things They Left Out (TTLO) v2.0
Tweak Network Settings v1.0
Wayback v0.2
Web Developer v0.9.3
X (Paranoia) v0.6.3

Note that a few of these may have been updated (via the software
update module) since being installed, but the version would be no more
then one or two off the latest. (I have the latest version of all
extensions installed according to the software update module.) Also, I
noticed this problem before installing Platypus v0.5; however it is
installed now (and didn't seem to make a difference with the problem).

Beyond that, Firefox is tweaked only visually. I do have "Block Ads
v.2004-06-12 by Neil Jenkins" in the userContent.css, though I can't
imagine how that would affect anything. Does anyone have a clue what
might be going on or how I could go about fixing this? I'm open to any
ideas because I can't WAIT to start tweaking and writing my own
scripts. >=D

Thanks for your help.

Peace. ~G

More information about the Greasemonkey mailing list