[Greasemonkey] Greasemonkey creates unusable gm_scripts on Linux

Matt Nordhoff mnordhoff at gmail.com
Sun Jul 31 21:40:46 EDT 2005


Aaron Boodman wrote:
> I uploaded a new version which creates the directory as 755. Would you
> mind double-checking that it works now?
> 
> On 7/31/05, chris feldmann <cfeldmann at gmail.com> wrote:
>> On 7/31/05, Matt Nordhoff <mnordhoff at gmail.com> wrote:
>>> Robert G. Werner wrote:
>>>> Matt Nordhoff wrote:
>>>>> Okay, this may or may not have been mentioned before, but gm_scripts is
>>>>> created readable and writable by the owner and readable by everyone
>>>>> else, but a directory also needs to be executable for it to be possible
>>>>> to enter it, so you have to manually chmod it 755. Could there be a
>>>>> check that makes sure the directory is usable?
>>>>>
>>>> I don't have this problem with the latest .5 GM release on FF 1.0.6 on
>>>> Linux (FC3).
>>  Created 755 here with greasemonkey, um, .5 I think (have there been a
>> couple of those?....):
>>  
>>  
>> drwxr-xr-x   2 axlotl users    4096 Jul 28 01:21 gm_scripts
>>  
>>  (2.6.11, firefox 1.06) Scripts are all 644.  Everything goes swimmingly. 
>>  
>>  
>>   
>>> Really? Huh. Unless I missed a release, well, I do. I guess I should
>>> note that this is in trunk nightlies... Haven't tried it in 1.0.6.

Hmm? Where?

-- 
Replace the point in my email address with a period to reply. ;-)


More information about the Greasemonkey mailing list