[Greasemonkey] 0.6.1.4 scripts not executing on some eBay pages

Aaron Boodman zboogs at gmail.com
Fri Sep 9 19:36:23 EDT 2005


On 9/9/05, Jason Diamond <jason at diamond.name> wrote:
> On 9/9/05, Tom Tobin <korpios at gmail.com> wrote:
> > On 9/9/05, Jason Diamond <jason at diamond.name> wrote:
> > > I'm using FF 1.0.6 on Ubuntu Linux 5.04 with GM 0.6.1.4 <http://0.6.1.4>. I
> >
> > It's my understanding that the Greasemonkey 0.6 line is intended for
> > Firefox 1.5, and will not work properly with the Firefox 1.0.
> 
> Really? The other user script I wrote is working perfectly with this set up.

Yeah, you will get really inconsistent results. Greasemonkey is using
an API that, while present in 1.0.x, was basically never used or
tested until Greasemonkey. It has all kinds of crazy bugs. I worked
with Mozilla developers to get it fixed for Deer Park.


More information about the Greasemonkey mailing list