<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
<tt><font size="+1">I got a similar error installing .03a,<br>
except it renamed my scripts directory</font><br>
<font size="+1">to ununderline.user.js. (the first<br>
script name listed in the scripts list)<br>
<br>
I think the problem is that it is trying<br>
to </font><font size="+1">migrate to the new format even though<br>
it was already done manually.<br>
<br>
Also, when I selected the Tools |<br>
Manage User Scripts... menu item,<br>
it didn't do anything.<br>
(because no scripts were installed?<br>
Worked via Extensions dialog Options button.<br>
<br>
But the Cancel button doesn't work.<br>
(as reported elsewhere)<br>
<br>
So, in config.xml, it changed all of the<br>
script references to:<br>
<br>
&lt;Script filename="" name=.....<br>
<br>
So, I fixed them manually, and it still tried to<br>
migrate the next time I started FF and it erased<br>
my changes again. Here is the JS error from the<br>
JS Console, which occured after the last logged<br>
message "Greasemonkey: renaming script scripts to linkify.user.js":<br>
<br>
Error: [Exception... "Component returned failure code: 0x80520012<br>
(NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.moveTo]"&nbsp; nsresult: "0x80520012<br>
(NS_ERROR_FILE_NOT_FOUND)"&nbsp; location: "JS frame ::<br>
<a class="moz-txt-link-freetext" href="chrome://greasemonkey/content/greasemonkey.js">chrome://greasemonkey/content/greasemonkey.js</a> ::<br>
GM_pointThreeMigrate :: line 540"&nbsp; data: no]<br>
Source File: <a class="moz-txt-link-freetext" href="chrome://greasemonkey/content/greasemonkey.js">chrome://greasemonkey/content/greasemonkey.js</a><br>
Line: 540<br>
<br>
I looked at the code and it is trying to do it again<br>
because it didn't set the pointThreeMigrated preference.<br>
So I just made the GM_pointThreeMigrate function return<br>
without doing anything. This code needs to be spiffed up some.<br>
It worked when I did the mod.<br>
<br>
btw -- that Edit button is a bit odd. (?)<br>
I can see a View script button, but Edit?<br>
Especially for "users". (versus programmers)<br>
(and it didn't work on Millennium Edition, even tho<br>
most things of that nature work -- I think the problem<br>
might be that .JS isn't defaulted to "edit", and<br>
I don't think we want it to be (?) --- because that<br>
would mess up other stuff (?))<br>
<br>
</font>Eddie S wrote:</tt>
<blockquote cite="mid3082bc03050416121012fedbd6@mail.gmail.com"
 type="cite"><tt>I got an alert box saying there was an error.<br>
It didnt update config.xml with the names it just gave the files. It<br>
didnt know where the scripts were as it renamed the folder. Whenever i<br>
right clicked "add user script" was visable. And generally confused<br>
itself.<br>
  <br>
After renaming the script folder back to scripts. Updating the<br>
config.xml file it now works again. But a file in the new name.user.js<br>
confused it. Just thought i would let you know.<br>
  <br>
  <br>
  </tt></blockquote>
</body>
</html>